Brock's Performance Homepage
Forum Home Forum Home > Technical Articles and Information > Product Discussions (Customers Welcome to add a Topic)
  New Posts New Posts RSS Feed - CT Single QK, PCV, Brocks/Guhl ECU 2 question
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

CT Single QK, PCV, Brocks/Guhl ECU 2 question

 Post Reply Post Reply
Author
Message
Darkarcher View Drop Down
Newbie
Newbie
Avatar

Joined: February/18/2016
Location: OH
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Darkarcher Quote  Post ReplyReply Direct Link To This Post Topic: CT Single QK, PCV, Brocks/Guhl ECU 2 question
    Posted: April/04/2016 at 12:02pm
Got my full Brocks setup installed on my 2015 zx14r. I have the Brocks/Guhl ECU flash 2, PCV currently loaded with the street/strip pump gas map, and the CT single Quiet Kore. I also performed the pair valve block that came with the exhaust.

First let me say that I love it. Really good linear power. I feel like I got at least a 10-15% increase in butt-dyno power, smoothness, drivability, street appeal(sound, looks etc etc).

On to my comments / questions:

I am getting a few gurgles and pop's coming from the exhaust from time to time during expecially if I do a quick roll off of the throttle or if i am modulating throttle on and off in the middle of the rpm range. It has been a bit chilly lately so maybe its the cold weather (engine temps in the 160 degree range) or maybe its because I am using 93 octane vs 89? I installed the exhaust myself and everything fits so perfectly that I cant imagine there are any issues there. I used the permatex copper on both ends of the header tubes but elected not to use it on the mid pipe or muffler. I dont hear any exhaust leak at idle or anything like that.

I figure since I am running the high performance map this is the AFR that I need for go fast and there might be a few pops now and again? Also I noticed when slowing down to the stop light it sort of does this loping idle thing as it comes down the last couple thousand rpm's. Once I come to a complete stop it smooths out nice and even.

So is this nature of the beast or something I should work on resolving? I am marking it down as nature of the beast unless you feel otherwise. I think about watching NHRA and how those funny cars spit and sputter as they pull up to the line (not that this is anything like that) but the point is you can nit pick anything to death I just want to confirm if any of this sounds concerning?
Back to Top
Steve6 View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: February/01/2013
Location: Ohio
Status: Offline
Points: 874
Post Options Post Options   Thanks (0) Thanks(0)   Quote Steve6 Quote  Post ReplyReply Direct Link To This Post Posted: April/04/2016 at 3:21pm
Darkarcher,
Glad that you are liking everything!  You are correct on all accounts by the way.  Everything that you are describing is perfectly normal.  Enjoy the new found performance!
Back to Top
timaugie View Drop Down
Newbie
Newbie
Avatar

Joined: May/10/2016
Location: Ft Lauderdale
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote timaugie Quote  Post ReplyReply Direct Link To This Post Posted: May/12/2016 at 10:37pm
I'm taking the fairings off of my 2015 ZX14 to install my Alienhead 2 exhaust and I came across a difference in my bike and the 2012 that is in the video.  When taking off the fairing (I'm only at the right side currently) the video says you just have to disconnect the turn signal but I also have 2 braided hoses attached to a plastic box inside the fairing.  Is this for ABS or something?  It looks like I will have to remove the inside plastic from the fairing in order to be able to get to this box for the disconnect?  I have a 2015 Anniversary edition if that helps.  Any ideas?
Back to Top
Steve6 View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: February/01/2013
Location: Ohio
Status: Offline
Points: 874
Post Options Post Options   Thanks (0) Thanks(0)   Quote Steve6 Quote  Post ReplyReply Direct Link To This Post Posted: May/13/2016 at 10:42am
timaugie, snap some photos if you would please and email them to sales@brocksperformance.com and we will see what we can find out for you.
Back to Top
toledoUPSguy View Drop Down
Newbie
Newbie


Joined: July/18/2012
Location: toledo, oh
Status: Offline
Points: 34
Post Options Post Options   Thanks (0) Thanks(0)   Quote toledoUPSguy Quote  Post ReplyReply Direct Link To This Post Posted: June/01/2016 at 5:50am
Do you have 2 stickers on your gas tank? the braided hoses on the right side fairing are going to the charcoal canister on the CA version.
The man on top of the mountain didn't fall there.

2014 zx14r in nuclear sunset orange and black.
Back to Top
timaugie View Drop Down
Newbie
Newbie
Avatar

Joined: May/10/2016
Location: Ft Lauderdale
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote timaugie Quote  Post ReplyReply Direct Link To This Post Posted: June/07/2016 at 11:47am
They figured it out for me, it was an idle speed controller. I ended up having to disconnect it from the plastic and just move it out of the way.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.